Sunbeam Rapier Owners Club
Sunbeam Rapier Owners Club
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 Sunbeam Rapier Owners Club
 General Chat
 MK3 Rapier Fuel Gauge/Water Temp not working
 New Topic  Reply to Topic
 Printer Friendly
New posts at top
New posts at bottom
Author Previous Topic Topic Next Topic  

John_Sunbeam

USA
2 Posts

Posted - 31 Mar 2020 :  00:00:34  Show Profile  Reply with Quote
Hello everyone, I have a series 3 sunbeam rapier and just recently the fuel gauge and water temp gauge stopped working fully. Any Ideas what it could be, I know the Series 3 does not have a voltage stabilizer but I am lost on what to do to fix it. Thanks in advance.

pruyter

Netherlands
283 Posts

Posted - 31 Mar 2020 :  09:21:46  Show Profile  Reply with Quote
Both the fuel gauge and the temp gauge have a green wire in common between them. This wire can be broken or loose. There where this green wire is connected to the fuel gauge there is at the same time a green wire which goes to the fuse box. This wire can be broken or loose too. Finally you could check the fuse itself (fuse no 4).

Regards,

Peter
Go to Top of Page

John_Sunbeam

USA
2 Posts

Posted - 31 Mar 2020 :  21:55:20  Show Profile  Reply with Quote
Where’s the fuse box?
Go to Top of Page

pruyter

Netherlands
283 Posts

Posted - 01 Apr 2020 :  09:47:18  Show Profile  Reply with Quote
In the engine bay against the fire wall.

Regards,

Peter
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
New posts at top
New posts at bottom
Jump To:
Sunbeam Rapier Owners Club © 2009 Sunbeam Rapier Owners Club Go To Top Of Page
Snitz Forums 2000